Shop Orchid Care OrchidTalk Orchid Forum Weather Station Links Nursery

Welcome to OrchidTalk Orchid Forums


The Friendliest Orchid Community on the Internet!


  •  » Learn to Repot your Orchids
  •  » Learn Orchid Care Tips and Secrets
  •  » Find the perfect Orchid for your Growing Environment
  •  » Chat with Orchid Growing Professionals

OrchidTalk - "Bringing People Together to Grow Orchids Better!"


Let us help you grow your Orchids better; Join our community today.


YES! I want to register an account for free right now!


Register or Login now to remove this advertisement.

Results 1 to 4 of 4

Yipes - what's wrong with my phrag????

This is a discussion on Yipes - what's wrong with my phrag???? within the Genus Specific forums, part of the Orchid Culture category; HELP!!!! This is my prized kovachii/Eric Young phrag hybrid. It has one pretty vigorous new ...

Click here to increase the font size Click here to reduce the font size
  1. #1
    mauraec's Avatar
    mauraec is offline Senior Member
    Real Name
    Maura Caffrey
    My Grow Area
    Outside 24/7
    Favorite Orchid(s)
    Paphiopedilum lowii
    Join Date
    May 2011
    Gender
    Female
    Location
    Englewood, FL
    Posts
    3,092
    Member's Country Flag

    Default Yipes - what's wrong with my phrag????




    HELP!!!!

    This is my prized kovachii/Eric Young phrag hybrid. It has one pretty vigorous new growth, and another one budding. However, it's real not happy and I've sacrificed one older growth leaf to show what it looks like. I got it from the slipper nursery last December, and it bloomed magnificently, despite having many of the marks on the leaves that I show below, so I just watched it.

    Now that I've seen how weird these marks are, I'm getting really worried. The spots and streaks are brown/rust/red and don't seem to have spread to the new growth yet, but the old growth is looking worse and worse.

    I've looked all over the place and can't find anything.

    What IS this? What do I do about it????

    I've taken a few shots to show what I'm talking about.


    Name:  phag closer still.jpg
Views: 266
Size:  43.1 KB

    Name:  phrag leaf closer.jpg
Views: 247
Size:  50.1 KB

    Name:  phrag closer 2.jpg
Views: 256
Size:  32.0 KB

    Name:  Phrag leaf.jpg
Views: 254
Size:  28.9 KB


  2. #2
    mauraec's Avatar
    mauraec is offline Senior Member
    Real Name
    Maura Caffrey
    My Grow Area
    Outside 24/7
    Favorite Orchid(s)
    Paphiopedilum lowii
    Join Date
    May 2011
    Gender
    Female
    Location
    Englewood, FL
    Posts
    3,092
    Member's Country Flag

    Default

    A few more shots, parts of the plant itself.

    Name:  phrag section plant.jpg
Views: 258
Size:  37.7 KB

    Name:  phrag plant closeup.jpg
Views: 235
Size:  31.5 KB

    Name:  phrag closeup on roots.jpg
Views: 255
Size:  45.5 KB

  3. #3
    Brutal_Dreamer's Avatar
    Brutal_Dreamer is offline Dreaming with my eyes open...
    Real Name
    Bruce Brown
    My Grow Area
    Greenhouse
    Favorite Orchid(s)
    Cattleyas & Slippers
    Join Date
    Mar 2003
    Gender
    Male
    Location
    Arkansas
    Posts
    34,003
    Member's Country Flag

    Default

    Looks like damage that was done some time ago. Maybe from old rust fungus-- probably from staying too wet. If it is not on the new growth, you are doing fine.

    cheers,
    BD

  4. #4
    mauraec's Avatar
    mauraec is offline Senior Member
    Real Name
    Maura Caffrey
    My Grow Area
    Outside 24/7
    Favorite Orchid(s)
    Paphiopedilum lowii
    Join Date
    May 2011
    Gender
    Female
    Location
    Englewood, FL
    Posts
    3,092
    Member's Country Flag

    Default

    Yay - Jason and I both have phrags from the same nursery and have seen the same issue. No, the new growth is unaffected, so I'm just guarding it caredully, and hoping for a spike to appear some time this fall - I realize tht may be a bit optimistic, but still....

Similar Threads

  1. Is there something going wrong here?
    By angela in forum **NOT IN BLOOM** All Genera
    Replies: 8
    Last Post: May 6th, 2012, 06:19 AM
  2. The wrong tag????
    By doodlekitty in forum General Orchid Culture
    Replies: 27
    Last Post: June 3rd, 2008, 10:20 AM
  3. What went wrong?
    By ang709 in forum General Orchid Culture
    Replies: 3
    Last Post: April 28th, 2008, 09:56 PM
  4. What have I done wrong here
    By GGordon in forum New Growers: Ask the Senior Members
    Replies: 10
    Last Post: July 14th, 2007, 07:49 PM
  5. YIPES! I'm going away....any suggestions?
    By Heather in forum General Orchid Culture
    Replies: 8
    Last Post: December 17th, 2004, 04:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
OrchidTalk --An Orchid Growers Discussion Forum brought to you by River Valley Orchidworks. A World Community where orchid beginners and experts talk about orchids and share tips on their care, cultivation, and propagation.