Shop Orchid Care OrchidTalk Orchid Forum Weather Station Links Nursery

Welcome to OrchidTalk Orchid Forums


The Friendliest Orchid Community on the Internet!


  •  » Learn to Repot your Orchids
  •  » Learn Orchid Care Tips and Secrets
  •  » Find the perfect Orchid for your Growing Environment
  •  » Chat with Orchid Growing Professionals

OrchidTalk - "Bringing People Together to Grow Orchids Better!"


Let us help you grow your Orchids better; Join our community today.


YES! I want to register an account for free right now!


Register or Login now to remove this advertisement.

Results 1 to 7 of 7

My S/H not doing as well as Roy's

This is a discussion on My S/H not doing as well as Roy's within the Semi Hydro / Lights / Greenhouses / Accessories forums, part of the Orchid Culture category; I try to flush it every time I top up the reservoir but this white ...

Click here to increase the font size Click here to reduce the font size
  1. #1
    Phyrex's Avatar
    Phyrex is offline .CA-member-t
    Real Name
    Richard
    My Grow Area
    Windowsill
    Favorite Orchid(s)
    Phals, Oncs, Neos, Paphs
    Join Date
    Jul 2007
    Location
    Vancouver, Canada
    Posts
    1,600
    Member's Country Flag
    Recipes
    1

    Default My S/H not doing as well as Roy's

    I try to flush it every time I top up the reservoir but this white stuff just doesn't want to stay away. The plant is not showing any bad signs yet but I'm sure it'll come soon. Is there anything I can do here? The plant is a NOID miltassia of some kind and I've only had it for a little while. I've just watered it before I took the picture.
    Attached Images Attached Images   

  2. #2
    Real Name
    Suzie
    My Grow Area
    On a Windowsill.
    Join Date
    Jul 2008
    Location
    Scottsdale, Arizona
    Posts
    36
    Member's Country Flag

    Default

    I am no SH expert- but you have some new root growth going on in the background---
    Some of the roots though they look dry and maybe even slightly torched-- I think it might be time to give those roots the axe-- at least that is what I'd do.
    How long have you had this plant in SH, Im sure other board members can provide better advice

  3. #3
    Gin's Avatar
    Gin
    Gin is offline Senior Member
    My Grow Area
    Greenhouse
    Favorite Orchid(s)
    All types
    Join Date
    Sep 2004
    Location
    Missouri
    Posts
    4,831
    Member's Country Flag

    Default

    Cookie is right , they have grown mold probably from dying and staying wet from not being able to use the moisture .
    I don't use s/h mine are in water lily baskets in Spag. Gin

  4. #4
    smartie2000's Avatar
    smartie2000 is offline Senior Member
    Real Name
    Fren
    My Grow Area
    Under Lights.
    Favorite Orchid(s)
    Phrags, Paphs, Catts
    Join Date
    Jan 2006
    Location
    Edmonton, Canada
    Posts
    2,202
    Member's Country Flag

    Default

    I only just got my package of hydroton...

    However I do know that old roots can die b/c o the medium change. Perhaps that is an old root?

  5. #5
    cindiras's Avatar
    cindiras is offline Senior Member
    Real Name
    Cindi
    My Grow Area
    Under Lights
    Favorite Orchid(s)
    Catts
    Join Date
    Nov 2007
    Location
    Central Iowa
    Posts
    1,766
    Member's Country Flag

    Default

    How long did you soak the hydroton and how many times did you change the rinse water? Could this be a mineral buildup from either your water or from the hydroton?

  6. #6
    Ron-NY is offline rothaholic
    Join Date
    Jan 2007
    Location
    Saratoga Co. New York
    Posts
    6,922

    Default

    the one root is above the medium so it is not staying wet. Are you sure that it is mold? There is a stage of scale with a white fuzzy look. it can occur on roots. pull back any dead leaf sheaths and look there also check under leaves for any other signs.

    It does look like mold to me but better safe than sorry. The roots could have gotten damaged during potting. the new roots look very healthy

    Old roots in the medium are expected to die but not always. I am on my second 50 lb bag of Hydroton

  7. #7
    ischel1's Avatar
    ischel1 is offline Senior Member
    Real Name
    Mary
    My Grow Area
    Greenhouse
    Favorite Orchid(s)
    Cattleya William Farrell
    Join Date
    Aug 2007
    Gender
    Female
    Location
    Gulf Coast
    Posts
    3,141
    Member's Country Flag

    Default

    Ron is right about the scale and I was also thinking maybe mealybug. Try some physan first in case it's mold and then if that doesn't work try an insecticide. My choice would be Neem oil.

Similar Threads

  1. Thwaitesara Roy's Magic in bloom
    By Brutal_Dreamer in forum Cattleyas, Vandas, Dendrobiums IN BLOOM
    Replies: 4
    Last Post: April 20th, 2009, 08:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
OrchidTalk --An Orchid Growers Discussion Forum brought to you by River Valley Orchidworks. A World Community where orchid beginners and experts talk about orchids and share tips on their care, cultivation, and propagation.